gscarousel 0.0.1

Flutter Android iOS web

A new Flutter package project.

0
likes
80 / 110
pub points
68 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://aguscahyo.com was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  warning: gscarousel has no library level documentation comments, from gscarousel: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:1:9)
  warning: unresolved doc reference [InheritedWidget]
    from gscarousel.GSCarouselState.build: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:109:10)
    in documentation inherited from framework.State.build: (file:///flutter/packages/flutter/lib/src/widgets/framework.dart:1424:10)
  warning: unresolved doc reference [AnimatedWidget]
    from gscarousel.GSCarouselState.build: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:109:10)
    in documentation inherited from framework.State.build: (file:///flutter/packages/flutter/lib/src/widgets/framework.dart:1424:10)
  warning: unresolved doc reference [ChangeNotifier]
    from gscarousel.GSCarouselState.dispose: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:104:8)
    in documentation inherited from framework.State.dispose: (file:///flutter/packages/flutter/lib/src/widgets/framework.dart:1312:8)
  warning: unresolved doc reference [Stream]
    from gscarousel.GSCarouselState.dispose: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:104:8)
    in documentation inherited from framework.State.dispose: (file:///flutter/packages/flutter/lib/src/widgets/framework.dart:1312:8)
  warning: gscarousel has no library level documentation comments, from gscarousel: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gsindicator.dart:1:9)
  error: failed to write file at: gscarousel/gscarousel-library.html
    for symbol gscarousel: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gsindicator.dart:1:9)
    conflicting with file already generated by gscarousel: (file:///tmp/pub-dartlang-dartdocGDOUGW/pkg/lib/gscarousel.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            gscarousel conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel-class.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/GSCarousel.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/animationCurve.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/animationDuration.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/autoPlay.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/autoPlayDuration.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/contentMode.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/createState.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/images.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorActiveColor.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorActiveSize.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorBackgroundColor.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorColor.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorSize.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarousel/indicatorSpacing.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState-class.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState/GSCarouselState.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState/build.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState/currentPosition.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState/dispose.html (from index.json)
  warning: dartdoc generated a broken link to: gscarousel/GSCarouselState/initState.html (from index.json)
found 27 warnings and 1 error
Unhandled exception:
dartdoc encountered 1 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:232:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/gscarousel.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/gsindicator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
68%
popularity

A new Flutter package project.

Homepage

Documentation

API reference

Uploader

cahyo.mamen@gmail.com

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on gscarousel