graphs 0.1.1

  • Example
  • Installing
  • Versions
  • 43

Build Status #

Graph algorithms which do not specify a particular approach for representing a Graph.

Functions in this package will take arguments that provide the mechanism for traversing the graph. For example two common approaches for representing a graph:

class Graph {
  Map<Node, List<Node>> nodes;
class Node {
  // Interesting data
class Graph {
  Node root;
class Node {
  List<Node> children;
  // Interesting data

Any representation can be adapted to the needs of the algorithm:

  • Some algorithms need to associate data with each node in the graph and it will be keyed by some type K that must work as a key in a HashMap. If nodes implement hashCode and ==, or if they are known to have one instance per logical node such that instance equality is sufficient, then the node can be passed through directly.
    • (node) => node
    • (node) =>
  • Algorithms which need to traverse the graph take a children function which provides the reachable nodes.
    • (node) => graph[node]
    • (node) => node.children

Graphs which are resolved asynchronously will have similar functions which return FutureOr.

0.1.1 #

  • crawlAsync will now ignore nodes that are resolved to null.

0.1.0 #

  • Initial release with an implementation of stronglyConnectedComponents and crawlAsync.


// Copyright (c) 2017, the Dart project authors.  Please see the AUTHORS file
// for details. All rights reserved. Use of this source code is governed by a
// BSD-style license that can be found in the LICENSE file.

import 'package:graphs/graphs.dart';

/// A representation of a directed graph.
/// Data is stored on the [Node] class.
class Graph {
  final Map<Node, List<Node>> nodes;

class Node {
  final String id;
  final int data;


  bool operator ==(Object other) => other is Node && == id;

  int get hashCode => id.hashCode;

  String toString() => '<$id -> $data>';

void main() {
  var nodeA = new Node('A', 1);
  var nodeB = new Node('B', 2);
  var nodeC = new Node('C', 3);
  var nodeD = new Node('D', 4);
  var graph = new Graph({
    nodeA: [nodeB, nodeC],
    nodeB: [nodeC, nodeD],
    nodeC: [nodeB, nodeD]

  var components = stronglyConnectedComponents<Node, Node>(
      graph.nodes.keys, (node) => node, (node) => graph.nodes[node]);


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  graphs: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:graphs/graphs.dart';
Version Uploaded Documentation Archive
0.2.0 Dec 12, 2018 Go to the documentation of graphs 0.2.0 Download graphs 0.2.0 archive
0.1.3+1 Nov 8, 2018 Go to the documentation of graphs 0.1.3+1 Download graphs 0.1.3+1 archive
0.1.3 Nov 7, 2018 Go to the documentation of graphs 0.1.3 Download graphs 0.1.3 archive
0.1.2+1 Jul 18, 2018 Go to the documentation of graphs 0.1.2+1 Download graphs 0.1.2+1 archive
0.1.2 Apr 23, 2018 Go to the documentation of graphs 0.1.2 Download graphs 0.1.2 archive
0.1.1 Apr 18, 2018 Go to the documentation of graphs 0.1.1 Download graphs 0.1.1 archive
0.1.0 Dec 7, 2017 Go to the documentation of graphs 0.1.0 Download graphs 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0