google_maps_place_picker 2.1.0-nullsafety.3
google_maps_place_picker: ^2.1.0-nullsafety.3 copied to clipboard

A Flutter plugin which provides 'Picking Place' using Google Maps widget.

201
likes
85/ 130
pub points
97%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 85 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:144:70

    ╷
144 │ adrAddress | String | A representation of the place's address in the <a href="http://microformats.org/wiki/adr">adr microformat</a>
    │                                                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 149 API elements (10.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:google_maps_place_picker/google_maps_place_picker.dart that imports:
  • package:google_maps_place_picker/src/place_picker.dart that imports:
  • package:google_maps_place_picker/src/google_map_place_picker.dart that imports:
  • package:google_maps_place_picker/providers/place_provider.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/autocomplete_search.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/components/prediction_tile.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
geolocator^7.0.17.7.17.7.1
google_api_headers^1.0.01.1.11.1.1
google_maps_flutter^2.0.12.1.12.1.1
google_maps_webservice^0.0.20-nullsafety.20.0.20-nullsafety.50.0.20-nullsafety.5
http^0.13.00.13.40.13.4
permission_handler^6.0.1+16.1.38.3.0
provider^5.0.05.0.06.0.1
tuple^2.0.0-nullsafety.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
ffi-1.1.21.1.2
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
geolocator_android-2.1.02.1.0
geolocator_apple-1.2.21.2.2
geolocator_platform_interface-2.3.62.3.6
geolocator_web-2.0.62.0.6
google_maps_flutter_platform_interface-2.1.32.1.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
package_info_plus-1.3.01.3.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
permission_handler_platform_interface-3.7.03.7.0
plugin_platform_interface-2.0.22.0.2
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.0.1+1` on permission_handler does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

The constraint `^5.0.0` on provider does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.