git 0.4.4+3

  • Readme
  • Changelog
  • Installing
  • 37

A dart wrapper around the Git command line #

Build Status

Authors #

0.4.4+3 #

  • Strong-mode fixes.

0.4.4+2 #

  • Internal refactoring.

0.4.4+1 #

  • Run git in the shell – trying to address issues on Windows.

0.4.4 #

  • Use which package to try harder to find git executable.

0.4.3 #

  • GitDir added updateBranchWithDirectoryContents.

0.4.2 #

  • Migrated code to Dart 1.9 async.

  • Improved testing.

0.4.1+2 #

  • Updated max version of bot dependency.

0.4.1+1 #

  • Updated hop and added hop_unittest dev dependencies.

0.4.1 - 2014-05-06 #

  • Tweaks to Commit to stop using deperecated APIs from bot.
  • Updated constraint on bot package.

0.4.0 - 2014-04-12 #

  • Made fields on TreeEntry final.
  • A lot of source clean up.

0.3.0 - 2014-03-17 #

  • BREAKING PopulateTempDir typedef.
  • BREAKING GitDir.populateBranch - moving away from TempDir from bot_io
  • Removed a number of package dependencies

0.2.1+1 - 2014-03-16 #

  • Moved scheduled_test dependency to dev_dependencies

0.2.1 - 2014-03-16 #

  • Deprecated PopulateTempDir typedef.
  • Deprecated GitDir.populateBranch - moving away from TempDir from bot_io
  • NEW! GitDir.updateBranch like populateBranch, but exposes a Directory

0.2.0 - 2014-03-04 #

  • Supporting next release of bot_io
  • Fixed hop_runner
  • Removed deprecated Git class.

0.1.0 - 2014-02-15 #

  • First release
  • Maintains 100% compatibility with the bot_git library from the bot_io package as of release 0.25.1+2.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  git: ^0.4.4+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:git/git.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0