geoflutterfire 3.0.0-nullsafety.2
geoflutterfire: ^3.0.0-nullsafety.2 copied to clipboard

GeoFlutterFire is an open-source library that allows you to store and query firestore documents based on their geographic location.

180
likes
130 / 130
pub points
96 %
popularity

We analyzed this package on May 11, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 35 API elements (37.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:geoflutterfire/geoflutterfire.dart that imports:
  • package:geoflutterfire/src/point.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^1.0.01.0.72.1.0
flutterflutter0.0.00.0.0
rxdart^0.26.00.26.00.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
cloud_firestore_platform_interface-4.0.35.0.1
cloud_firestore_web-1.0.72.0.1
collection-1.15.01.15.0
firebase_core-1.1.11.1.1
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.0.31.0.3
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on cloud_firestore does not support the stable version `2.0.0`, that was published 6 days ago.

When cloud_firestore is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`, that was published 4 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

180
likes
130
pub points
96%
popularity

Publisher

noeatsleepteam.com

GeoFlutterFire is an open-source library that allows you to store and query firestore documents based on their geographic location.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter, rxdart

More

Packages that depend on geoflutterfire