geo_firestore 0.0.1

Flutter Android iOS

GeoFirestore for Flutter to do location based queries with Firestore

8
likes
75 / 110
pub points
70 %
popularity

We analyzed this package on Sep 24, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 20 API elements (55.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:geo_firestore/geo_firestore.dart that imports:
  • package:geo_firestore/src/geo_utils.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:geo_firestore/geo_firestore.dart that imports:
  • package:geo_firestore/src/geo_utils.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:geo_firestore/geo_firestore.dart that imports:
  • package:geo_firestore/src/geo_utils.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:geo_firestore/geo_firestore.dart that imports:
  • package:geo_firestore/src/geo_utils.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^0.12.20.12.110.14.0+2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
firebase-7.3.07.3.0
firebase_core-0.4.50.5.0
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.9
meta-1.1.81.2.3
path-1.7.01.7.0
pedantic-1.9.01.9.2
plugin_platform_interface-1.0.21.0.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.2` on cloud_firestore does not support the latest published version `0.14.0+2`

pubspec.yaml:14:20

   ╷
14 │   cloud_firestore: ^0.12.2
   │                    ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

8
likes
75
pub points
70%
popularity

GeoFirestore for Flutter to do location based queries with Firestore

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

joscmw95@gmail.com

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter

More

Packages that depend on geo_firestore