full_calendar 0.0.1
full_calendar: ^0.0.1

Flutter Android iOS web

A new Flutter package project.

FullCalendar #

English | 简体中文

A calendar plugin for Flutter

Installation #

Added on pubspec.yaml file dependencies

full_calendar: ^0.0.1

Run in your terminal

flutter packages get

Example #

FullCalendar(
  min: DateTime(2018),
  max: DateTime(2021),
  onChange: (value) {
    print(value);
  },
),

Api #

  • value
    • DateTime
    • The time currently selected
  • min
    • DateTime
    • The minimum time
  • max
    • DateTime
    • Maximum time
  • onChange
    • void Function(DateTime)
    • A callback after selecting the time

to-do #

  • [x] Single time selection
  • [] Multiple time selection
  • [] Time period selection
  • [] Custom theme
0
likes
90
pub points
0%
popularity

A new Flutter package project.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

allanhx211@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on full_calendar