fo 0.0.2

fo #

Build Status Coverage Status

Implementation of assoc, assoc-in(assocIn), get-in(getIn) from clojure in dart

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fo: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fo/fo.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
39
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/src/assoc.dart. (-1.99 points)

Analysis of lib/src/assoc.dart reported 4 hints:

line 7 col 12: Unnecessary new keyword.

line 7 col 37: Unnecessary new keyword.

line 9 col 12: Unnecessary new keyword.

line 9 col 36: Unnecessary new keyword.

Fix lib/src/assoc_in.dart. (-0.50 points)

Analysis of lib/src/assoc_in.dart reported 1 hint:

line 13 col 28: Unnecessary new keyword.

Maintenance suggestions

Package is getting outdated. (-32.33 points)

The package was last published 69 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fo.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <3.0.0
Dev dependencies
test >=0.12.24+2 <0.13.0