fm_ota_update 1.0.1

  • Readme
  • Changelog
  • Installing
  • 61

base on ota_update #

ota_update #

1.0.3 #

  • fixed compatibility for older Android APIs (by zileyuan)

1.0.2 #

  • ios syntax error fix (by tchunwei)

1.0.1 #

  • migration of embeded example to AndroidX
  • Upgraded Gradle to latest version

1.0.0 #

  • migration to AndroidX and boost compileVersion to 28 (by tchunwei)

0.1.3 #

  • extended Android FileProvider to prevent possible conflicts with other plugins that also use FileProvider.

0.1.2 #

  • fixing NullPointerException when onRequestPermissionsResult was triggered by different plugin than this one

0.1.1 #

  • refactor to use streams only as communication channel
  • documentation changes

0.1.0 #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fm_ota_update: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fm_ota_update/generated/i18n.dart';
import 'package:fm_ota_update/ota_update.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/ota_update.dart.

Run flutter format to format lib/ota_update.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/hhwy/ota_update was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fm_ota_update.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8