flyme_annotation 0.0.3

  • Readme
  • Changelog
  • Installing
  • new49

language: English | 简体中文

flyme_annotation #

Just for Flutter.

Annotation for flame_generator.

Getting Started #

Properties #

Properties: a property list.

Property #

Property: describe instance's property. And it has three properties:

  • name: property's name.
  • type: property's type.
  • initial: property's initialized value.

How to use #

just see the code:

@Properties([
  Property(name: "name", type: "String", initial: ""),
  Property(name: "age", type: "num", initial: "-1"),
  Property(
      name: "user",
      type: "User",
      initial: '''User(name: "", age: -1, email: "")'''),
  Property(name: "foo", type: "String"),
  Property(name: "boo", type: "String", initial: "something"),
])
class TestModel extends _ViewModelProxy {
  @override
  void init() {
    print("==== Test init ====");
  }
}

[0.0.3] - update docs. #

  • update docs.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flyme_annotation: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flyme_annotation/flyme_annotation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • flyme_annotation that is a package requiring null.

Maintenance issues and suggestions

Documentation URL doesn't exist. (-10 points)

At the time of the analysis the documentation field https://github.com/maybewaityou/flyme_annotation/blob/master/README.md was unreachable.

Repository URL doesn't exist. (-10 points)

At the time of the analysis the repository field https://github.com/maybewaityou/flyme_annotation was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flyme_annotation.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test