fluttertheoremreach 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new49

fluttertheoremreach #

Non-official Flutter plugin for Theorem Reach. Feel free to help :)

Getting Started #

Initialize the TheoremReach plugin with a API token and a User ID.

FlutterTheoremreach().init(apiToken: 'yourtoken', userId: 'youruserid');

Show Panel #

FlutterTheoremreach().show();

Customize Panel #

Set Navigation Bar text

FlutterTheoremreach().setNavBarText(text: 'yourtext');

Set Navigation Bar color

FlutterTheoremreach().setNavBarColor(color: 'hexcolor');

Set Navigation Bar text color

FlutterTheoremreach().setNavBarTextColor(textColor: 'hexcolor');

0.0.1 - 2020-06-16 #

  • Working plugin for Android with functions: - Init - Show - setNavBarText - setNavBarColor - setNavBarTextColor

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:fluttertheoremreach/fluttertheoremreach.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  void initState() {
    super.initState();
    FlutterTheoremreach().init(apiToken: 'yourtoken', userId: 'youruserid');
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: RaisedButton(
            child: Text("theorem"),
            onPressed: () => FlutterTheoremreach().show(),
          )
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluttertheoremreach: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluttertheoremreach/fluttertheoremreach.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:fluttertheoremreach/fluttertheoremreach.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:fluttertheoremreach/fluttertheoremreach.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:fluttertheoremreach/fluttertheoremreach.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:fluttertheoremreach/fluttertheoremreach.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [fluttertheoremreach] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/fluttertheoremreach.dart.

Run flutter format to format lib/fluttertheoremreach.dart.

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test