flutterskel 0.0.17
flutterskel: ^0.0.17 copied to clipboard

Flutter Android iOS web

A flutter package that provides the basic architecture

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/shannonrodricks/flutterskel was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 211 API elements (6.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: RawBaseStatelessWidget._context

lib/widgets/stateless/RawStatelessWidget.dart:18:16

   ╷
18 │ abstract class RawBaseStatelessWidget<
   │                ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/stateless/RawStatelessWidget.dart

lib/configuration/Configuration.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
provider>=3.0.0+1 <4.0.03.2.04.3.3
rxdart>=0.22.0 <1.0.00.25.00.25.0
shared_preferences>=0.5.3+2 <1.0.00.5.12+40.5.12+4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.2+20.0.2+2
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=3.0.0+1 <4.0.0` on provider does not support the latest published version `4.3.3`

pubspec.yaml:14:13

   ╷
14 │   provider: ">=3.0.0+1 <4.0.0"
   │             ^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

A flutter package that provides the basic architecture

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

shanrod220@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, provider, rxdart, shared_preferences

More

Packages that depend on flutterskel