A flutter plugin to use wechat.
Add this to your package's pubspec.yaml file:
dependencies: flutter_wechat: ^0.0.4
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.5||Jul 3, 2018|
|0.1.2||Apr 22, 2018|
|0.1.1||Apr 22, 2018|
|0.1.0||Apr 21, 2018|
|0.0.9||Apr 19, 2018|
|0.0.8||Apr 19, 2018|
|0.0.7||Apr 18, 2018|
|0.0.6||Apr 18, 2018|
|0.0.5||Apr 18, 2018|
|0.0.4||Apr 18, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on May 30, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Document public APIs. (-1 points)
9 out of 9 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
flutter format to format
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is getting outdated. (-11.51 points)
The package was last published 58 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
flutter_wechat.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.