flutter_umeng_analytics_fork 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

flutter_umeng_analytics #

Flutter plugin for umeng:analytics

Usage #

Init #

import 'package:platform/platform.dart';

final Platform platform = const LocalPlatform();
if (platform.isAndroid)
  UMengAnalytics.init('Android AppKey',
          policy: Policy.BATCH, encrypt: true, reportCrash: false);
else if (platform.isIOS)
  UMengAnalytics.init('iOS AppKey',
          policy: Policy.BATCH, encrypt: true, reportCrash: false);

Log page #

initState() {


dispose() {


someFunction() {
  UMengAnalytics.logEvent("some click");

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1] #

  • initial release.


import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_umeng_analytics_fork/flutter_umeng_analytics_fork.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  static bool _inited;
  initState() {

    if (_inited == null) {
      _inited = true;
          policy: Policy.BATCH, encrypt: true, reportCrash: false);

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        body: new Center(
          child: new Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: [
            new RaisedButton(
              onPressed: () {
              child: new Text('Running on: hello'),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_umeng_analytics_fork: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_umeng_analytics_fork/flutter_umeng_analytics_fork.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

14 out of 14 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutter_umeng_analytics_fork.dart. (-3.93 points)

Analysis of lib/flutter_umeng_analytics_fork.dart reported 8 hints, including:

line 6 col 20: Name non-constant identifiers using lowerCamelCase.

line 7 col 20: Name non-constant identifiers using lowerCamelCase.

line 8 col 20: Name non-constant identifiers using lowerCamelCase.

line 9 col 20: Name non-constant identifiers using lowerCamelCase.

line 35 col 23: This function has a return type of 'Future

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Package is getting outdated. (-31.78 points)

The package was last published 68 weeks ago.

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8