flutter_taped 0.0.1
flutter_taped: ^0.0.1 copied to clipboard

A new Flutter package project.

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
Unhandled exception:
fatal error: unable to locate the input directory at /tmp/pub-cache-dirLZACTR/hosted/pub.dartlang.org/tape-0.0.4/lib/src/adapters.
#0      PubPackageMeta.fromDir (package:dartdoc/src/package_meta.dart:232:7)
#1      PubPackageMeta.fromFilename (package:dartdoc/src/package_meta.dart:219:27)
#2      PackageMetaProvider.fromFilename (package:dartdoc/src/package_meta.dart:68:54)
#3      PubPackageBuilder._packageMetasForFiles (package:dartdoc/src/model/package_builder.dart:174:57)
#4      PubPackageBuilder._parseLibraries (package:dartdoc/src/model/package_builder.dart:231:17)
<asynchronous suspension>
#5      PubPackageBuilder.getLibraries (package:dartdoc/src/model/package_builder.dart:402:11)
<asynchronous suspension>
#6      PubPackageBuilder.buildPackageGraph (package:dartdoc/src/model/package_builder.dart:71:11)
<asynchronous suspension>
#7      Dartdoc.generateDocsBase (package:dartdoc/dartdoc.dart:182:41)
#8      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:223:34)
#9      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#10     _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#11     _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

ERROR: Undefined class 'TapeApi'.

lib/flutter_taped.dart:7:27

  ╷
7 │ extension FlutterTaped on TapeApi {
  │                           ^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_taped.dart

ERROR: The method 'registerAdapters' isn't defined for the type '

lib/flutter_taped.dart:9:5

  ╷
9 │     registerAdapters({
  │     ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_taped.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because every version of tapegen depends on dartx ^0.4.1 which depends on collection >=1.14.11 <1.15.0, every version of tapegen requires collection >=1.14.11 <1.15.0.
And because every version of flutter_test from sdk depends on collection 1.15.0-nullsafety.3, tapegen is incompatible with flutter_test from sdk.
So, because flutter_taped depends on both flutter_test any from sdk and tapegen ^0.0.2, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

0
likes
40
pub points
0%
popularity

A new Flutter package project.

Repository (GitHub)
View/report issues

Uploader

marcel.garus@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, tape

More

Packages that depend on flutter_taped