flutter_stabilisers 0.0.2

  • Readme
  • Changelog
  • Installing
  • 44

Flutter-Stabilisers #

Dealing with errors is a daily - sometimes hourly - task of almost every developer. A task usually followed by a long time looking for help on StackOverflow or GitHub.

Flutter-Stabilisers automatically looks for solutions to your errors on StackOverflow and GitHub Issues, saving your precious time for those really hard-to-solve bugs.

Getting started #

Add the following dependency to pubspec.yaml:

dependencies:
  ...
  flutter_stabilisers:
    git:
      url: git://github.com/johnlina/flutter_stabilisers.git
      ref: master

In your main.dart add the following import:

import 'package:flutter_stabilisers/flutter_stabilisers.dart';

Call Stabilisers.config() before running your app

void main() {

  Stabilisers.config();

  runApp(MyApp());

}

And that's all! Now all your error messages will be automatically searched on StackOverflow and GitHub Issues.

Checking the results #

You can check the results at the console of your IDE.

The error stack will be suppressed by default. If you want to view the full error stack on your console along with the search results you can set the flag on the config() method call.

void main() {

  Stabilisers.config(suppressStack: false);

  runApp(MyApp());

}

[0.0.2] - 01/06/2019.

  • Initial release with all basic functionalities working :)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_stabilisers: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_stabilisers/flutter_stabilisers.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Dec 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutter_stabilisers.dart. (-3.45 points)

Analysis of lib/flutter_stabilisers.dart reported 7 hints, including:

line 57 col 17: Name non-constant identifiers using lowerCamelCase.

line 66 col 117: Avoid using braces in interpolation when not needed.

line 66 col 127: Avoid using braces in interpolation when not needed.

line 70 col 11: The label 'https' isn't used.

line 73 col 79: Avoid using braces in interpolation when not needed.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_stabilisers.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test