flutter_sliding_nav 0.1.2

  • Readme
  • Changelog
  • Installing
  • 38

flutter_sliding_nav #

pub package


flutter_sliding_nav provides you with the SlidingRoot widget which takes a slideable front widget which is rendered over a back widget, this can be used to make unique intuitive gesture interfaces

Pub Package
Example Code

Usage #

new SlidingRoot(
    back: new Container(
        decoration: new BoxDecoration(color: Colors.white)
    ),

    front: new Container(
        decoration: new BoxDecoration(color: Colors.black)
    )
)

This renders a black colored screen which you can swipe from left edge to the right to reveal a white colored back widget

Example #

GIF


Example Code



made with ❤️ by andrew bastin

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_sliding_nav: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_sliding_nav/flutter_sliding_nav.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
44
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [flutter_sliding_nav] that is in a package requiring null.

Health suggestions

Fix lib/flutter_sliding_nav.dart. (-1 points)

Analysis of lib/flutter_sliding_nav.dart reported 2 hints:

line 112 col 63: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..

line 112 col 89: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

Maintenance suggestions

Package is getting outdated. (-56.44 points)

The package was last published 81 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and flutter_sliding_nav.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test