flutter_simple_video_player 0.0.9

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 84

flutter_page_video #

Flutter 视频播放插件

依赖 #

dependencies:
  flutter_simple_video_player: ^0.0.9

示例 #

import 'package:flutter/material.dart';
import 'package:flutter_simple_video_player/simple_video_player.dart';

void main() {
  runApp(MaterialApp(
      home: MyApp()
  ));
}

// http://184.72.239.149/vod/smil:BigBuckBunny.smil/playlist.m3u8
class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text("Demo"),
      ),
      body: Container(
        height: 300.0,
        child: SimpleViewPlayer("http://184.72.239.149/vod/smil:BigBuckBunny.smil/playlist.m3u8", isFullScreen: false,),
      )
    );
  }
}

[0.0.1] - 2018-08-06

  • 全屏播放视频

[0.0.5] - 2018-08-06

  • 修复bug

[0.0.9] - 2019-03-01

  • 简化代码

example/README.md

example #

flutter video example

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_simple_video_player: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_simple_video_player/flutter_simple_video_player.dart';
  
Version Uploaded Documentation Archive
0.0.9 Mar 1, 2019 Go to the documentation of flutter_simple_video_player 0.0.9 Download flutter_simple_video_player 0.0.9 archive
0.0.8 Dec 21, 2018 Go to the documentation of flutter_simple_video_player 0.0.8 Download flutter_simple_video_player 0.0.8 archive
0.0.7 Nov 6, 2018 Go to the documentation of flutter_simple_video_player 0.0.7 Download flutter_simple_video_player 0.0.7 archive
0.0.6 Aug 16, 2018 Go to the documentation of flutter_simple_video_player 0.0.6 Download flutter_simple_video_player 0.0.6 archive
0.0.5 Aug 16, 2018 Go to the documentation of flutter_simple_video_player 0.0.5 Download flutter_simple_video_player 0.0.5 archive
0.0.4 Aug 16, 2018 Go to the documentation of flutter_simple_video_player 0.0.4 Download flutter_simple_video_player 0.0.4 archive
0.0.3 Aug 16, 2018 Go to the documentation of flutter_simple_video_player 0.0.3 Download flutter_simple_video_player 0.0.3 archive
0.0.2 Aug 6, 2018 Go to the documentation of flutter_simple_video_player 0.0.2 Download flutter_simple_video_player 0.0.2 archive
0.0.1 Aug 6, 2018 Go to the documentation of flutter_simple_video_player 0.0.1 Download flutter_simple_video_player 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
82
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on May 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/flutter_simple_video_player.dart. (-1.49 points)

Analysis of lib/flutter_simple_video_player.dart reported 3 hints:

line 7 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: SimpleViewPlayer.isFullScreen

line 73 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: PlayView.controller, PlayView.allowFullScreen

line 97 col 7: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
screen ^0.0.4 0.0.5
video_player ^0.10.0+2 0.10.1
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test