flutter_showtime 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new63

flutter_showtime #

A flutter wrapper around the ShowTime Cocoapod. Allows you to easily view touch events in iOS.

https://github.com/KaneCheshire/ShowTime

Requires minimum deployment target of 8.2 or higher.

Note: this is a no-op in Android and is only valid for iOS.

AsYouType real-time formatting

Getting Started #

Add this project to your pubspec.yaml:

  flutter_showtime: ^0.0.2

Enable / disable touch events:

await FlutterShowtime.enable();

API Reference #

Future<void> enable() #

Enable visible touch events.

Future<void> disable() #

Disable visible touch events.

0.1.1 #

  • Fixed typo in pubspec description.

0.1.0 #

  • Added dart doc comments.

0.0.2 #

  • Updated readme to include link to ShowTime package.

0.0.1 #

  • Initial release.

example/lib/main.dart

import 'package:flutter/cupertino.dart';
import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_showtime/flutter_showtime.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  var showtimeEnabled = false;

  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
          appBar: AppBar(
            title: const Text('flutter_showtime'),
          ),
          body: Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: [
              Spacer(),
              Center(
                child: RaisedButton(
                  onPressed: () async {
                    if (showtimeEnabled) {
                      await FlutterShowtime.disable();
                      setState(() => showtimeEnabled = false);
                    } else {
                      await FlutterShowtime.enable();
                      setState(() => showtimeEnabled = true);
                    }
                  },
                  child: Text('ShowTime Enabled: $showtimeEnabled'),
                ),
              ),
              Spacer(),
            ],
          )),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_showtime: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_showtime/flutter_showtime.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:flutter_showtime/flutter_showtime.dart that declares support for platforms: ios

Package does not support Flutter platform linux

Because:

  • package:flutter_showtime/flutter_showtime.dart that declares support for platforms: ios

Package does not support Flutter platform macos

Because:

  • package:flutter_showtime/flutter_showtime.dart that declares support for platforms: ios

Package does not support Flutter platform web

Because:

  • package:flutter_showtime/flutter_showtime.dart that declares support for platforms: ios

Package does not support Flutter platform windows

Because:

  • package:flutter_showtime/flutter_showtime.dart that declares support for platforms: ios

Package not compatible with SDK dart

Because:

  • flutter_showtime that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test