flutter_rtmp_publisher_md 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

flutter_rtmp_publisher #

This Plugins helps to brodcast Live via RTMP right from your flutter application. In a single Line of code.

Under the hood plugins uses SRS(Simple-RTMP-Server) for Android and LFLiveKit for iOS

Supported Platforms

  • Android
  • iOS

How to use #

# add this line to your dependencies
flutter_rtmp_publisher: ^0.0.1
import 'package:flutter_rtmp_publisher/flutter_rtmp_publisher.dart';
// To start the stream call
RTMPPublisher.streamVideo("<PLACE_YOUR_RTMP_STREAM_URL>");

It only takes one required parameter i.e., url

  • Make sure your app has camera permission

Preview Images #

If you need any features suggest #

if you like it please star

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_rtmp_publisher/flutter_rtmp_publisher.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter RTMP Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  const MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {


  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: const Text('Flutter RTMP Demo'),
      ),
      body: Container(
        child: RaisedButton(
          child: Text("Start Stream"),
          onPressed: () {
            RTMPPublisher.streamVideo("<PLACE_YOUR_RTMP_STREAM_URL>");
          },
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_rtmp_publisher_md: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_rtmp_publisher_md/flutter_rtmp_publisher.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Linux

Because:

  • package:flutter_rtmp_publisher_md/flutter_rtmp_publisher.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Web

Because:

  • package:flutter_rtmp_publisher_md/flutter_rtmp_publisher.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Windows

Because:

  • package:flutter_rtmp_publisher_md/flutter_rtmp_publisher.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform macOS

Because:

  • package:flutter_rtmp_publisher_md/flutter_rtmp_publisher.dart that declares support for platforms: Android, iOS

Package not compatible with SDK dart

Because:

  • flutter_rtmp_publisher_md that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_rtmp_publisher.dart.

Run flutter format to format lib/flutter_rtmp_publisher.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test