flutter_responsive_cursor 0.0.3

Flutter Responsive Cursor #

About #

A replacement for Flutter's EditableText with native-like cursor behavior. The cursor stays on while typing and fades in and out rather than blinking.

Usage #

import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';

var _controller = TextEditingController();

ResponsiveCursorEditableText(
    controller: _controller,
    cursorColor: Colors.lightBlue,
    focusNode: FocusNode(),
    style: Theme.of(context).textTheme.body1,
);

ResponsiveCursorTextField(
    cursorColor: Colors.lightBlue,
    style: Theme.of(context).textTheme.body1,
);

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/example.dart

import 'package:flutter/material.dart';
import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  var _controller = TextEditingController.fromValue(TextEditingValue(text: 'Hello'));

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            ResponsiveCursorEditableText(
              controller: _controller,
              cursorColor: Colors.lightBlue,
              focusNode: FocusNode(),
              style: Theme.of(context).textTheme.body1,
            ),
            ResponsiveCursorTextField(
              cursorColor: Colors.lightBlue,
              style: Theme.of(context).textTheme.body1,
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_responsive_cursor: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
33
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

We analyzed this package on Sep 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/flutter_responsive_cursor.dart. (-67.36 points)

Analysis of lib/flutter_responsive_cursor.dart failed with 3 errors, 5 warnings, including:

line 397 col 7: Missing concrete implementations of TextInputClient.updateFloatingCursor, getter TextSelectionDelegate.copyEnabled, getter TextSelectionDelegate.cutEnabled, getter TextSelectionDelegate.pasteEnabled and 1 more.

line 658 col 9: The named parameter 'layerLink' isn't defined.

line 873 col 28: The method 'reparentIfNeeded' isn't defined for the class 'FocusScopeNode'.

line 654 col 27: The parameter 'endHandleLayerLink' is required.

line 654 col 27: The parameter 'startHandleLayerLink' is required.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
rxdart ^0.19.0 0.19.0 0.22.2
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test