flutter_required_field 0.1.2

Flutter Android iOS web

Package which allows require input from user.

0
likes
60 / 100
pub points
6 %
popularity

We analyzed this package on Sep 14, 2020, and awarded it 60 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://gitlab.com/nogipx/flutter_required_field.git was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/InputField.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/InputFieldList.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.23.10.23.10.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:14:11

   ╷
14 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
6%
popularity

Publisher

dart.nogipx.ru

Package which allows require input from user.

Repository (GitLab)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on flutter_required_field