flutter_plus 0.0.2
flutter_plus: ^0.0.2 copied to clipboard

Develop applications in Flutter more quickly and easily. Customize Containers, Buttons, Texts and TextFields in a few lines. Navigate between Screens and open BottomSheets, Dialogs and Snackbars witho

31
likes
40 / 110
pub points
68 %
popularity

We analyzed this package on Mar 26, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 70 out of 370 API elements (18.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_plus/flutter_plus_exports.dart that imports:
  • package:flutter_plus/src/widgets/widgets_export_plus.dart that imports:
  • package:flutter_plus/src/widgets/src/text_plus.dart that imports:
  • package:flutter_plus/plus.dart that imports:
  • package:flutter_plus/src/utils/utils_export_plus.dart that imports:
  • package:flutter_plus/src/utils/src/local_storage_plus.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

ERROR: The named parameter 'child' isn't defined.

lib/src/utils/src/dialog_plus.dart:34:7

   ╷
34 │       child: this._createDialog(
   │       ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/src/dialog_plus.dart

WARNING: The parameter 'builder' is required.

lib/src/utils/src/dialog_plus.dart:27:5

   ╷
27 │     showDialog(
   │     ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/src/dialog_plus.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
diacritic^0.1.10.1.30.1.3
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.17.0
path^1.7.01.8.01.8.0
shared_preferences^0.5.12+40.5.12+42.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.42.0.4
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

The constraint `^0.5.12+4` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.3, Dart 2.12.2.

31
likes
40
pub points
68%
popularity

Develop applications in Flutter more quickly and easily. Customize Containers, Buttons, Texts and TextFields in a few lines. Navigate between Screens and open BottomSheets, Dialogs and Snackbars without context from any point.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

gbmiranda92@gmail.com

License

MIT (LICENSE)

Dependencies

diacritic, flutter, intl, path, shared_preferences

More

Packages that depend on flutter_plus