添加依赖：在pubspec.yaml中添加依赖： dependencies: flutter_plugin_system: ^0.0.3//最新版本号 获取依赖包：flutter packages get 使用： import 'package:flutter_plugin_system/flutter_plugin_system.dart'; //获取系统缓存： String cacheSize=await FlutterPluginSystem.getCacheSize(); //判断是否使用vpn: bool isUsedVpn=await FlutterPluginSystem.isVpnUsed(); //获取应用包名： String pakageName= await FlutterPluginSystem.getAppPakageName(); //清除缓存 bool isClear = await FlutterPluginSystem.clearCache();
Demonstrates how to use the flutter_plugin_system plugin.
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Add this to your package's pubspec.yaml file:
dependencies: flutter_plugin_system: ^1.0.2
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.2||Dec 23, 2018|
|1.0.1||Dec 23, 2018|
|1.0.0||Dec 23, 2018|
|0.0.4||Dec 20, 2018|
|0.0.3||Dec 20, 2018|
|0.0.2||Dec 20, 2018|
|0.0.1||Dec 20, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
flutter format to format
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.