flutter_plugin_system 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 36

插件描述 #

调用原生系统的一些工具插件,目前只支持android端!加入ios后会在此处进行说明!

如何使用 #

添加依赖:在pubspec.yaml中添加依赖:
    dependencies:
      flutter_plugin_system: ^0.0.3//最新版本号
      
获取依赖包:flutter packages get

使用:
    import 'package:flutter_plugin_system/flutter_plugin_system.dart';
    //获取系统缓存:
    String cacheSize=await FlutterPluginSystem.getCacheSize();
    //判断是否使用vpn:
    bool isUsedVpn=await FlutterPluginSystem.isVpnUsed();
    //获取应用包名:
    String pakageName= await FlutterPluginSystem.getAppPakageName();
    //清除缓存
    bool isClear = await FlutterPluginSystem.clearCache();
    

0.0.1 #

  • TODO: Describe initial release.

1.0.0 #

  • TODO:增加判断是否有网络

1.0.1 #

  • TODO: 修改启动WebActivity

1.0.2 #

  • TODO: 修改isHaveNetWork安卓端

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_plugin_system/flutter_plugin_system.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  String mcacheSize="";
  bool isHaveNetWork=false;
  @override
  void initState() {
    super.initState();
    initPlatformState();
    getCacheSize();
    getNetWorkStatues();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await FlutterPluginSystem.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n$mcacheSize\n$isHaveNetWork'),
        ),
      ),
    );
  }

  void getCacheSize() async {
    String cacheSize = await FlutterPluginSystem.getCacheSize();
    setState(() {
      mcacheSize=cacheSize;
    });
  }

  void getNetWorkStatues() async{
    bool isHave=await FlutterPluginSystem.isHaveNetWork();
    setState(() {
      isHaveNetWork=isHave;
    });
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_plugin_system: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_plugin_system/flutter_plugin_system.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
28
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_plugin_system/flutter_plugin_system.dart]

Package does not support Flutter platform macos

Because of import path [package:flutter_plugin_system/flutter_plugin_system.dart]

Package does not support Flutter platform web

Because of import path [package:flutter_plugin_system/flutter_plugin_system.dart]

Package does not support Flutter platform windows

Because of import path [package:flutter_plugin_system/flutter_plugin_system.dart]

Package not compatible with SDK dart

because of import path [flutter_plugin_system]

Health suggestions

Format lib/flutter_plugin_system.dart.

Run flutter format to format lib/flutter_plugin_system.dart.

Maintenance suggestions

Package is getting outdated. (-52.33 points)

The package was last published 79 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8