flutter_playfab 0.2.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 50

flutter_playfab #

A package to integrate flutter with PlayFab

Usage #

Import package:flutter_playfab/flutter_playfab.dart, and instantiate PlayFab

Implemented Endpoints #

  • Authentication
    • LoginWithIOSDeviceID
    • LoginWithAndroidDeviceID
  • Analytics
    • WritePlayerEvent

Example:

import 'package:flutter_playfab/flutter_playfab.dart';



//Logging in
void initState() {
    Playfab.init("YOUR_TITLE_ID");
    Playfab.debugMode = true;
    Playfab.logIn();
}

//Sending events
Playfab.sendEvent("event_name");

//Sending events with Body params
Playfab.sendEvent("event_name",{"param1":1,"param2":"value2"});

[0.2.1] - 07/01/2019

  • Queue Sequence Bug Fix

[0.2.0] - 06/01/2019

  • Changed PlayFab to Static Library

[0.1.1] - 28/12/2018

  • Added MIT License

[0.1.0] - 28/12/2018

  • Login
  • Send Event Logs

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_playfab: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_playfab/flutter_playfab.dart';
  
Version Uploaded Documentation Archive
0.3.5 Feb 3, 2019 Go to the documentation of flutter_playfab 0.3.5 Download flutter_playfab 0.3.5 archive
0.3.4 Feb 3, 2019 Go to the documentation of flutter_playfab 0.3.4 Download flutter_playfab 0.3.4 archive
0.3.3 Feb 3, 2019 Go to the documentation of flutter_playfab 0.3.3 Download flutter_playfab 0.3.3 archive
0.3.2 Jan 31, 2019 Go to the documentation of flutter_playfab 0.3.2 Download flutter_playfab 0.3.2 archive
0.3.1 Jan 31, 2019 Go to the documentation of flutter_playfab 0.3.1 Download flutter_playfab 0.3.1 archive
0.3.0 Jan 31, 2019 Go to the documentation of flutter_playfab 0.3.0 Download flutter_playfab 0.3.0 archive
0.2.2 Jan 9, 2019 Go to the documentation of flutter_playfab 0.2.2 Download flutter_playfab 0.2.2 archive
0.2.1 Jan 7, 2019 Go to the documentation of flutter_playfab 0.2.1 Download flutter_playfab 0.2.1 archive
0.2.0 Jan 6, 2019 Go to the documentation of flutter_playfab 0.2.0 Download flutter_playfab 0.2.0 archive
0.1.1 Dec 28, 2018 Go to the documentation of flutter_playfab 0.1.1 Download flutter_playfab 0.1.1 archive

All 11 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
93
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/flutter_playfab.dart. (-6.78 points)

Analysis of lib/flutter_playfab.dart reported 14 hints, including:

line 44 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 112 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 175 col 11: Avoid wrapping fields in getters and setters just to be "safe".

line 176 col 7: Avoid wrapping fields in getters and setters just to be "safe".

line 177 col 14: Avoid wrapping fields in getters and setters just to be "safe".

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
device_info ^0.3.0 0.3.0 0.4.0+1
flutter 0.0.0
http ^0.12.0 0.12.0+2
shared_preferences ^0.4.3 0.4.3 0.5.2
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.6.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test