flutter_photokit_kotlinupg 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 65

iOS PhotoKit Plugin for Flutter #

A Flutter plugin to interact with PhotoKit on iOS.

Usage #

To use this plugin, add flutter_photokit_kotlinupg as a dependency in your pubspec.yaml file

Then, include the NSPhotoLibraryAddUsageDescription permission in your Info.plist

Example #

For an example on how to use this plugin, check out the sample app

For simplicity, the sample app just shows an example of saving a photo, but this plugin will work for videos as well! Usage is exactly the same.

0.0.1 #

example/README.md

flutter_photokit_example #

Demonstrates how to use the flutter_photokit plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_photokit_kotlinupg: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_photokit_kotlinupg/flutter_photokit_kotlinupg.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_photokit_kotlinupg.dart.

Run flutter format to format lib/flutter_photokit_kotlinupg.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
path_provider 0.4.1