flutter_page_router 0.1.0
flutter_page_router: ^0.1.0 copied to clipboard

A front-end develop-oriented Routing Manage library that route params, context less programmatic navigation and global hooks.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_page_router

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  flutter_page_router: ^0.1.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_page_router/flutter_page_router.dart';
1
likes
80
pub points
34%
popularity

Publisher

Unknown

A front-end develop-oriented Routing Manage library that route params, context less programmatic navigation and global hooks.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_page_transition, get_it

More

Packages that depend on flutter_page_router