flutter_page_indicators 0.0.1

pub package

flutter_page_indicator #

Page indicator for flutter, with multiple build-in layouts.

NOTE:this project is a fork of flutter_page_indicator, because the author doesn't maintain any more.

Show cases #

showcases

Installation #

Add


flutter_page_indicators:

to your pubspec.yaml ,and run

flutter packages get 

in your project's root directory.

Basic Usage #

new PageIndicator(
  layout: PageIndicatorLayout.SLIDE,
  size: 20.0,
  controller: YOUR_PAGE_CONTROLLER,
  space: 5.0,
  count: 4,
)

All build-in layouts #

| :------------ |:---------------:|:---------------:| | PageIndicatorLayout.NONE | | From 0.0.1 | | PageIndicatorLayout.SLIDE | | From 0.0.1 | | PageIndicatorLayout.WARM | | From 0.0.1 | | PageIndicatorLayout.COLOR | | From 0.0.1 | | PageIndicatorLayout.SCALE | | From 0.0.1 | | PageIndicatorLayout.DROP | | From 0.0.1 |

[0.0.3]

* Fix bugs
* Support loop mode for layout: PageIndicatorLayout.COLOR & PageIndicatorLayout.COLOR.
* Modify all `PageIndicatorLayout` values to uppercase.

[0.0.2]

* Update readme 

[0.0.1]

* Basic usage
* PageIndicatorLayout.NONE
* PageIndicatorLayout.SLIDE
* PageIndicatorLayout.WARM
* PageIndicatorLayout.COLOR
* PageIndicatorLayout.SCALE
* PageIndicatorLayout.DROP

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_page_indicators: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_page_indicators/flutter_page_indicators.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
89
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test