flutter_ogury 0.0.2

Flutter Android iOS

A flutter plugin for the Ogury sdk

Flutter Ogury SDK #

Unofficial plugin for integrating the Ogury SDK. Currently only supports interstitial ads! Please be aware that major changes could be coming.

Installation #

iOS #

Make sure to set the deployment target to iOS 10.0 inside you Podfile!

platform :ios, '10.0'

iOS and Android #

Go to your Ogury Dashboard and register your application. Note down asset key.

Create an Interstitial ad unit and note down the ad unit id.

Add the plugin to your pubspec.yaml

flutter_ogury: ^0.1.1

Usage #

Initialise the Ogury SDK preferably inside main.dart.

/// Initialises the Ogury SDK
  FlutterOgury.initialize(
    assetKeyAndroid: "OGY-XXXXXXXXXXXX",
    assetKeyIOS: "OGY-XXXXXXXXXXXX",
  );

Load the sdk as soon as possible

FlutterOgury.loadInterstitial(
      adUnitIdAndroid: "123456_default",
      adUnitIdIOS: "123456_default",
      enableTestAd: true,
    );

Check if the interstitial ad has been loaded

bool interstitialIsLoaded = await FlutterOgury.interstitialIsLoaded();

Show the interstitial ad

FlutterOgury.showInterstitial();

Contributing #

Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

Please make sure to update tests as appropriate.

License #

MIT