flutter_myfatoorah_payment 1.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 51

MyFatoorah Payment Gateway Plugin #

A flutter plugin for integrating MyFatoorah payment gateway. Supports Android and iOS.

Installing #

Add this in pubspec.yaml

  dependencies:
    flutter_myfatoorah_payment: ^1.0.4

iOS 9+ Specific #

ios developers should add the following to their plist

<key>NSAppTransportSecurity</key>
<dict>
    <key>NSAllowsArbitraryLoads</key>
    <true/>
    <key>NSAllowsArbitraryLoadsForMedia</key>
    <true/>
    <key>NSAllowsArbitraryLoadsInWebContent</key>
    <true/>
</dict>

Using #

import 'package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart';
startpayment() async {
    //Testing Credentials
    String credEmail = "apiaccount@myfatoorah.com";
     String credPass = "api12345*";
     int language = 0;
     String name = "JP";
     double price = 111.0;
  
    String paymentMethod = ".all";
    var response ;
    Map<dynamic, dynamic> map = {"cred_url":credUrl,
                                "cred_email":credEmail,
                                "cred_pass":credPass,
                                "language":language,
                                "name":name,
                                "price":price,
                                "payment_method":paymentMethod};
    try {
           response = await FlutterMyfatoorah.payment(map);
        } on PlatformException {
            print('error');
        }
}

See the example directory for a complete sample app.

Responses : #

Sucess Response:
    all data about payment done in json string format

Error Response:
    cancelled by user: {"Error":"Payment Cancelled"}
  
    Gateway Errors: {"Error":"ssl error","responseCode":"500"}

1.0.4 #

  • plugin version

0.0.3 #

  • iOS support added.

0.0.2 #

  • Android support added.

1.0.1 #

  • MyFatoorah Payment Gateway plugin.

example/lib/main.dart

import 'package:flutter/cupertino.dart';
import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String result = 'Tap Pay';

  @override
  void initState() {
    super.initState();
  }

  Future<void> startpayment() async {
    //test credentials
    String credUrl = "https://apidemo.myfatoorah.com/";

    String credEmail = "apiaccount@myfatoorah.com";
    String credPass = "api12345*";
    int language = 0;
    String name = "JP";
    double price = 111.0;
    String paymentMethod = ".all";
    String data;
    Map<dynamic, dynamic> map = {"cred_url":credUrl,
                              "cred_email":credEmail,
                              "cred_pass":credPass,
                              "language":language,
                              "name":name,
                              "price":price,
                              "payment_method":paymentMethod};
    try {
          data = await FlutterMyfatoorahPayment.paymentMyfatoorah(map);
        } on PlatformException {
          data = 'Failed';
        }
    setState(() {
      result = data;
      print(result);
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin MyFatoorah'),
        ),
        body:  Center(
          child: Column(
            mainAxisAlignment: MainAxisAlignment.center,
              children: <Widget>[
                FlatButton(
                  color: Colors.grey,
                  child: Text("Pay"), 
                  onPressed: (){
                    startpayment();
                  },
                ),
                SizedBox(),
                Text(result),
              ],
            ),
        ),
        ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_myfatoorah_payment: ^1.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:flutter_myfatoorah_payment/flutter_myfatoorah_payment.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • flutter_myfatoorah_payment that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_myfatoorah_payment.dart.

Run flutter format to format lib/flutter_myfatoorah_payment.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/jp-android/Myfatoorahpayment---plugin.git was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test