ESRI basemaps for flutter_map. This does NOT provide esri FeatureLayers or other layers.
new FlutterMap( options: new MapOptions( center: new LatLng(34.0231688, -118.2874995), zoom: 17.0, ), layers: [ new EsriBasemapOptions( esriBasemapType: EsriBasemapType.streets), ], );
EsriBasemapOptions implements TileLayerOptions.
Add this to your package's pubspec.yaml file:
dependencies: flutter_map_esri: ^0.0.2
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.4||Aug 21, 2018|
|0.0.3||May 18, 2018|
|0.0.2||May 17, 2018|
|0.0.1||May 17, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0 <2.0.0|