flutter_map 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 79

flutter_map #

Experimental

See the github repository for documentation

[0.1.0] - 8/21/2018

  • Set Dart SDK to ">=2.0.0 <3.0.0"

[0.0.11] - 8/2/2018

  • upgrade to latlong from 0.4.0 to 0.5.3

[0.0.11] - 7/31/2018

  • fix LICENSE spelling error
  • double-tap to zoom (#62)
  • Fix polyline overlap issue (#67)
  • Offline map example (#53)

Thanks to contributors @alfanhui, @avioli, @solid-software, and @vinicentus for this release!

[0.0.10] - 6/7/2018

  • update .gitignore (#40)
  • Applied constraints to zoom on gesture update if min or max options set (#46)
  • Pan Boundary with 2 new MapOptions variables: swPanBoundary and nePanBoundary (#47)
  • OfflineMode bool variable added to TileLayerOptions for AssetImage Widget use (#48)
  • remove quiver dep (#32)

Thanks to contributors @avioli, @bcko, and @alfanhui for this release!

[0.0.9] - 5/31/2018

  • add LatlngBounds.contains, avoid rendering out-of-view markers in MarkerLayer

[0.0.8] - 5/31/2018

  • bug: rendering far-away tiles was causing a GPU crash on the simulator. add tile pruning to TileLayer

[0.0.7] - 5/29/2018

  • bug: TileLayer not listening to onMoved events from MapController

[0.0.6] - 5/11/2018

  • fitBounds, onPositionChanged (#39)

[0.0.5] - 3/11/2018

  • make tile background customizable (#36)
  • use transparent_image as placeholder image (#37)

[0.0.4] - 4/18/2018

  • Add marker anchor support (#27, #30)

[0.0.3] - 4/18/2018

  • fixed Dart 2.0 type errors (#23)
  • add MapController API (#24 + #25)

[0.0.2] - 2/21/2018

  • subdomain support
  • move gesture detection into map widget
  • improved tile layer support
  • improved examples
  • Polyline layers
  • fix marker redraw on map rotation

[0.0.1] - 2/5/2018

  • inital release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_map: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_map/flutter_map.dart';
  
Version Uploaded Documentation Archive
0.5.3+1 May 23, 2019 Go to the documentation of flutter_map 0.5.3+1 Download flutter_map 0.5.3+1 archive
0.5.3 May 21, 2019 Go to the documentation of flutter_map 0.5.3 Download flutter_map 0.5.3 archive
0.5.2 May 20, 2019 Go to the documentation of flutter_map 0.5.2 Download flutter_map 0.5.2 archive
0.5.1 May 17, 2019 Go to the documentation of flutter_map 0.5.1 Download flutter_map 0.5.1 archive
0.5.0+1 Apr 23, 2019 Go to the documentation of flutter_map 0.5.0+1 Download flutter_map 0.5.0+1 archive
0.5.0 Feb 21, 2019 Go to the documentation of flutter_map 0.5.0 Download flutter_map 0.5.0 archive
0.4.0 Jan 1, 2019 Go to the documentation of flutter_map 0.4.0 Download flutter_map 0.4.0 archive
0.3.0 Nov 1, 2018 Go to the documentation of flutter_map 0.3.0 Download flutter_map 0.3.0 archive
0.2.0 Oct 25, 2018 Go to the documentation of flutter_map 0.2.0 Download flutter_map 0.2.0 archive
0.1.4 Sep 24, 2018 Go to the documentation of flutter_map 0.1.4 Download flutter_map 0.1.4 archive

All 32 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/src/core/center_zoom.dart.

Run flutter format to format lib/src/core/center_zoom.dart.

Format lib/src/core/point.dart.

Run flutter format to format lib/src/core/point.dart.

Format lib/src/geo/crs/crs.dart.

Run flutter format to format lib/src/geo/crs/crs.dart.

Format lib/src/layer/layer.dart.

Run flutter format to format lib/src/layer/layer.dart.

Format lib/src/layer/polyline_layer.dart.

Run flutter format to format lib/src/layer/polyline_layer.dart.

Maintenance issues and suggestions

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: latlong.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_map.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
latlong 0.5.3
transparent_image ^0.1.0 0.1.0 1.0.0
tuple ^1.0.0 1.0.2
Transitive dependencies
ansicolor 1.0.2
collection 1.14.11
console_log_handler 1.1.6
intl 0.15.8
logging 0.11.3+2
matcher 0.12.5
meta 1.1.6 1.1.7
path 1.6.2
quiver 2.0.3
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
validate 1.7.0
vector_math 2.0.8