flutter_magnetometer 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 70

flutter_magnetometer #

Supports Android only atm #

To start using this add import 'package:flutter_magnetometer/flutter_magnetometer.dart';to your imports section.

Then you can simply listen to new events from the sensor via FlutterMagnetometer.events.listen((MagnetometerData data) => doStuff(data));.

An example app with a compass and raw sensor data in the UI can be found in ther example folder.

Getting Started #

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Changelog #

0.1.1 #

  • improve code performance by replacing stupid map conversions

0.1.0 #

  • API is stable at this point

0.0.1 #

  • intial working release

example/lib/main.dart

import 'dart:async';
import 'dart:math' as math;

import 'package:flutter/material.dart';
import 'package:flutter_magnetometer/flutter_magnetometer.dart';

void main() => runApp(MagnetometerExampleApp());

class MagnetometerExampleApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.red,
      ),
      home: CompassPage(),
    );
  }
}

class CompassPage extends StatefulWidget {
  @override
  State<StatefulWidget> createState() => _CompassPageState();
}

class _CompassPageState extends State<CompassPage> {
  MagnetometerData _magnetometerData = MagnetometerData(0.0, 0.0, 0.0);

  StreamSubscription _magnetometerListener;

  /// assign listener and start setting real data over [_magnetometerData]
  @override
  void initState() {
    super.initState();
    _magnetometerListener = FlutterMagnetometer.events
        .listen((MagnetometerData data) => setState(() => _magnetometerData = data));
  }

  @override
  void dispose() {
    _magnetometerListener.cancel();
    super.dispose();
  }

  @override
  Widget build(BuildContext context) {
    final double atan2 = math.atan2(_magnetometerData.y, _magnetometerData.x);
    return Scaffold(
      appBar: AppBar(
        title: Text('Flutter Magnetometer Example'),
      ),
      body: ListView(
        semanticChildCount: 3,
        children: <Widget>[
          Center(
            child: Padding(
              padding: EdgeInsets.all(16.0),
              child: Transform.rotate(
                // calculate the direction we're heading in degrees, then convert to radian
                angle: math.pi / 2 - atan2,
                child: Image.asset('assets/compass.webp'),
              ),
            ),
          ),
          Text('Raw microtesla values: \n: ${_magnetometerData.toStringDeep()}'),
          Text('atan2 result:\n $atan2'),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_magnetometer: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_magnetometer/flutter_magnetometer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
44
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/flutter_magnetometer.dart. (-0.50 points)

Analysis of lib/flutter_magnetometer.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:convert'.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (equatable).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
equatable ^0.3.0 0.3.0 1.1.1
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test