flutter_location 0.0.6

Flutter Location Plugin #

A Flutter plugin to provide native location.

WARN: This plugin was written in swift/kotlin to be able to use it, you should have created the project with:

    flutter create -i swift -a kotlin project_name

Getting Started #

For help getting started with Flutter, view our online documentation. For help on editing plugin code, view the documentation.

Add the dependency to your pubspec.yaml file.

dependencies:
  flutter_location: ^0.0.4

For iOS device, add these in lines in the Info.plist file:

<key>NSLocationWhenInUseUsageDescription</key>
<string>This message will be display to the user</string>

For android device, add these in lines in the AndroidManifest.xml file:

<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />

Then import the plugin in your code:

import 'package:flutter_location/flutter_location.dart'; // Plugin
import 'package:flutter_location/permission.dart'; // Return type
import 'package:flutter_location/location.dart'; // Return type

Look into the example for utilisation:

Location _location;
Location _currentLocation;
 @override
  void initState() {
    super.initState();
    initLocation();
  }

  Future<Permission> initPermission() async {
    Permission permission;
    bool isDetermined = false;
    await FlutterLocation.requestPermission;
    while (!isDetermined) {
      permission = await FlutterLocation.permission;
      if (permission == Permission.NOT_DETERMINED) {
        await Future.delayed(_waitForUser);
      } else {
        isDetermined = true;
      }
    }
    return permission;
  }

  void initLocation() async {
    Permission permission;
    permission = await initPermission();
    Location location;
    if (permission == Permission.AUTHORIZED) {
      location = await FlutterLocation.location;
      FlutterLocation.onLocationChanged.listen(
        (location) {
          setState(() => this._currentLocation = location);
        },
      );
    }
    setState(() {
      this._permission = permission;
      this._location = location;
    });
  }

For more examples check out:

API #

MethodsDescription
FutureGet the level of permission the user has granted to the app (NOT_DETERMINED, DENIED, AUTHORIZED).
FutureGet the location of the user.
StreamGet the stream of the user's location.
FutureShow pop-up to the user to accept or decline permission authorizations. true if the pop-up was shown false if not (only will request once to show the popup)

Model #

Permission: #

  • NOT_DETERMINED: Permission not specified
  • DENIED: The user rejected the authorization
  • AUTHORIZED: The user granted permission to use location

Location { #

  • double latitude
  • double longitude
  • double accuracy, // in iOS horizontal accuracy
  • double altitude
  • double speed

0.0.1 #

Initial commit

0.0.2 #

Adds iOS support

0.0.3 #

Bug fixing

0.0.4 #

Now Location is a class instead of generic Map<String, double> Documentation is improved

0.0.5 #

Adds android support, adds requestPermission, renames permissionLevel to permission

0.0.6 #

Bug fixing

example/README.md

flutter_location_example #

Demonstrates how to use the flutter_location plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_location: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_location/flutter_location.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

31 out of 31 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8