flutter_loan_calculator 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 65

flutter_loan_calculator #

A new Flutter package which helps developers in creating loan calculator of their app.

Screenshots #

Usage #

Example

To use this package :

  dependencies:
    flutter:
      sdk: flutter
    flutter_loan_calculator:

How to use #

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {

  String description = "Some description ..."
      "Some description ..."
      "Some description ..."
      "Some description ...";

  @override
  Widget build(BuildContext context) {
    return PaymentGenerator(
       description: description,
    );
  }
}

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference. "# Flutter-Loan-Calculator"

0.0.1 #

  • A loan calculator library written in dart.

0.0.2 #

  • Fix minor bugs.

1.0.0 #

  • Color choices and appearance change.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_loan_calculator/flutter_loan_calculator.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      debugShowCheckedModeBanner: false,
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {

  String description = "When you want to buy a house, you can find a suitable residence or"
      "through the X application of consumer loan rates"
      "by comparing your loan application on a single page"
      "you can easily.";

  @override
  Widget build(BuildContext context) {
    return PaymentGenerator(
      description: description,
      selectedTabLabelColor: Colors.green,
      unselectedTabLabelColor: Colors.grey,
      unselectedTabBorderColor: Colors.grey,
      selectedTabBorderColor: Colors.purple,
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_loan_calculator: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_loan_calculator/flutter_loan_calculator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [flutter_loan_calculator] that is in a package requiring null.

Health suggestions

Format lib/flutter_loan_calculator.dart.

Run flutter format to format lib/flutter_loan_calculator.dart.

Format lib/pages/table_page.dart.

Run flutter format to format lib/pages/table_page.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test