flutter_jsc 0.0.1+1
flutter_jsc: ^0.0.1+1 copied to clipboard

A Flutter ffi project,provide JavaScriptCore feature in Flutter

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Jan 22, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 12 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_jsc/flutter_jsc.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

ERROR: The method 'free' isn't defined for the type 'Pointer'.

lib/src/utils/arena.dart:25:11

   ╷
25 │       ptr.free();
   │           ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/arena.dart

ERROR: The type 'ffi.Struct' is declared with 0 type parameters, but 1 type arguments were given.

lib/src/utils/utf8.dart:11:20

   ╷
11 │ class Utf8 extends ffi.Struct<Utf8> {
   │                    ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/utf8.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

Publisher

xin1t.com

A Flutter ffi project,provide JavaScriptCore feature in Flutter

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_jsc