Flutter polyfills for dart:js APIs
This polyfills APIs in dart:js, which is not included in the Flutter SDK. This allows flutter and non-flutter packages to co-exist in the same IntelliJ package. An example of this is described here: https://github.com/apptreesoftware/letsvote#intellj-multi-module-setup
Add this to your package's pubspec.yaml file:
dependencies: flutter_js_polyfill: ^2.0.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|2.0.1||Aug 17, 2018|
|2.0.0||Jun 26, 2018|
|1.0.2||Jun 25, 2018|
|1.0.1||Jun 14, 2018|
|1.0.0||Jun 14, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: web, other
Document public APIs. (-1 points)
2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
flutter_js_polyfill.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.0.0 <3.0.0|