flutter_instagram_stories 0.1.5+7
flutter_instagram_stories: ^0.1.5+7 copied to clipboard

Flutter Android iOS

Display stories (videos and images) like Whatsapp & Instagram.

59
likes
90 / 110
pub points
76 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 73 out of 297 API elements (24.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_instagram_stories/flutter_instagram_stories.dart that imports:
  • package:flutter_instagram_stories/grouped_stories_view.dart that imports:
  • package:flutter_instagram_stories/models/stories_data.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.5.02.5.02.5.0
cloud_firestore^0.14.30.14.41.0.0
dotted_border^1.0.71.0.71.0.7
firebase_core^0.5.30.5.31.0.0
flutterflutter0.0.00.0.0
flutter_cache_manager^2.0.02.1.02.1.1
json_annotation^3.1.03.1.14.0.0
rxdart^0.25.00.25.00.26.0
sqflite1.3.21.3.22.0.0+2
video_player^1.0.11.0.12.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
cloud_firestore_platform_interface-2.2.14.0.0
cloud_firestore_web-0.2.1+21.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
firebase_core_platform_interface-2.1.04.0.0
firebase_core_web-0.2.1+11.0.0
flutter_blurhash-0.5.00.5.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
image-2.1.193.0.1
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
octo_image-0.3.00.3.0
path-1.8.01.8.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider-1.6.272.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
petitparser-3.1.04.0.2
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.1.04.1.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-2.0.0+12.0.0+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.1
vector_math-2.1.02.1.0
video_player_platform_interface-2.2.04.0.0
video_player_web-0.1.4+12.0.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.14.3` on cloud_firestore does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^0.5.3` on firebase_core does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.