flutter_in_app 0.0.3

flutter_billing #

A plugin for Flutter that enables communication with billing API in iOS and Android.

This plugin implements in app purchases rather than Android Pay or Apple Pay. Both Apple and Google collect fees upon each successful transaction made using this plugin.

Warning: This plugin is still under development, some billing features are not available yet and testing has been limited. Feedback and Pull Requests are welcome.

Using #

Add flutter_billing flutter_billing as a dependency in pubspec.yaml.

Create an instance of the plugin:

final Billing billing = new Billing(onError: (e) {
  // optionally handle exception

Request available products for purchase:

final List<BillingProduct> products = await billing.getProducts(<String>[


final BillingProduct product = await billing.getProduct('my.product.id');
if (product != null) {
  // success
} else {
  // something went wrong

Request purchased products (each purchase is a product identifier):

final Set<String> purchases = await billing.getPurchases();

Check if a product is already purchased:

final bool purchased = purchases.contains('my.product.id');


final bool purchases = await billing.isPurchased('my.product.id');

Purchase a product:

final bool purchased = await billing.purchase(productId);

Limitations #

This is just an initial version of the plugin. There are still some limitations:

  • Only non-consumable in app products are supported

0.2.2 #

  • Fix on iOS to return price in cents ($1.99 = 199)

0.2.1 #

  • Report Exception instead of Error as per type in Dart 2

0.2.0 #

  • Breaking change. Dart 2 support

0.1.3 #

  • On iOS product price was passed as double to Dart code

0.1.2 #

  • Skip a product if information is not fulfilled properly

0.1.1 #

  • iOS Support. Library is tested on iOS. Feature parity for both iOS and Android.

0.1.0 #

  • New breaking API to address caching of products and purchases.

0.0.2 #

  • Basic documented API

0.0.1 #

  • Initial Release


import 'package:flutter/material.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  initState() {

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        body: new Center(
          child: new Text('Billing.'),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_in_app: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_in_app/flutter_in_app.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Fix lib/flutter_in_app.dart. (-1.99 points)

Analysis of lib/flutter_in_app.dart reported 4 hints:

line 95 col 12: 'synchronized' is deprecated and shouldn't be used. Use Lock() instead.

line 133 col 12: 'synchronized' is deprecated and shouldn't be used. Use Lock() instead.

line 161 col 12: 'synchronized' is deprecated and shouldn't be used. Use Lock() instead.

line 182 col 12: 'synchronized' is deprecated and shouldn't be used. Use Lock() instead.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (synchronized).

Package is getting outdated. (-78.36 points)

The package was last published 93 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
synchronized ^1.1.0 1.5.3+2 2.2.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8