flutter_hkgrid80_wgs84_converter 0.0.1

  • Readme
  • Changelog
  • Installing
  • 71

flutter_hkgrid80_wgs84_converter #

This package allows you to convert WGS 84 Latitude and Longitude to Hong Kong Grid 1980 Easting and Northing.

Usage #

Add this repository to pubspec.yaml.

Example:

dependencies:
    flutter:
        sdk: flutter
    flutter_hkgrid80_wgs84_converter:
        git: 
            url: git://github.com/lowkahonn/flutter_hkgrid80_wgs84_converter
            ref: master

Import package:flutter_hkgrid80_wgs84_converter/flutter_hkgrid80_wgs84_converter.dart, and use Converter.convert to convert between the two systems.

Note: This converter is up to 1e-5% error.

Example:

import 'package:flutter_hkgrid80_wgs84_converter/flutter_hkgrid80_wgs84_converter.dart';

final coordinate = new Coordinate(
    x: 834349.252, 
    y: 815894.556,
    lat: 22.281927, 
    lng: 114.158256
);

// from x y to lat long
Coordinate latLng = Converter.convert.gridToLatLng(coordinate);
print(latLng.lat.toString()); // 22.281930012478536 
print(latLng.lng.toString()); // 114.15824821181121

// from lat long to x y
Coordinate xy = Converter.convert.latLngToGrid(coordinate);
print(xy.x.toString()); // 834350.1488648592
print(xy.y.toString()); // 815894.2762260285

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_hkgrid80_wgs84_converter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_hkgrid80_wgs84_converter/flutter_hkgrid80_wgs84_converter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
54
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

50 out of 50 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/models/constants.dart. (-4.89 points)

Analysis of lib/models/constants.dart reported 10 hints, including:

line 10 col 8: Name non-constant identifiers using lowerCamelCase.

line 13 col 8: Name non-constant identifiers using lowerCamelCase.

line 14 col 8: Name non-constant identifiers using lowerCamelCase.

line 15 col 8: Name non-constant identifiers using lowerCamelCase.

line 16 col 8: Name non-constant identifiers using lowerCamelCase.

Format lib/flutter_hkgrid80_wgs84_converter.dart.

Run flutter format to format lib/flutter_hkgrid80_wgs84_converter.dart.

Format lib/models/converter.dart.

Run flutter format to format lib/models/converter.dart.

Format lib/models/coordinate.dart.

Run flutter format to format lib/models/coordinate.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_hkgrid80_wgs84_converter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test