flutter_gt_push_plugin 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 43

flutter_gt_push_plugin #

A new Flutter plugin with push

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.4 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart';
import 'package:flutter_gt_push_plugin/flutter_gt_delegate.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  GtPushServer _server = GtPushServer();

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;

    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

class GtPushServer implements FlutterGtDelegate {
  FlutterGtPushPlugin push = FlutterGtPushPlugin();

  GtPushServer() {
    push.setupWithAppID(
        appId: 'pakNhnuVra897u9TQOz7G6',
        appKey: 'bFQzHgCBA17GlCzyEyEy76',
        appSecret: 'U35S7Mh2uL99zhJAh9G4F3');
    push.delegate = this;
  }

  @override
  void GeTuiSdkDidReceiveMessage(String message) {
    print('收到个推消息');
  }

  @override
  void GeTuiSdkDidRegisterClient(String clientId) {
    print('注册个推ID $clientId');
  }

  // iOS VOIP用来消息透传后逻辑处理
  @override
  void didReceiveIncomingPushWithPayload(Map payloadMap) {
    print('iOS didReceiveIncomingPushWithPayload ${payloadMap}');
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_gt_push_plugin: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_gt_push_plugin/flutter_gt_push_plugin.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_gt_push_plugin] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

20 out of 20 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutter_gt_delegate.dart. (-1 points)

Analysis of lib/flutter_gt_delegate.dart reported 2 hints:

line 6 col 8: Name non-constant identifiers using lowerCamelCase.

line 8 col 8: Name non-constant identifiers using lowerCamelCase.

Fix lib/flutter_gt_push.dart. (-1 points)

Analysis of lib/flutter_gt_push.dart reported 2 hints:

line 1 col 8: Unused import: 'flutter_gt_delegate.dart'.

line 2 col 8: Unused import: 'flutter_gt_push_plugin.dart'.

Fix lib/flutter_gt_push_plugin.dart. (-0.50 points)

Analysis of lib/flutter_gt_push_plugin.dart reported 1 hint:

line 15 col 16: The value of the field '_onOpenNotification' isn't used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test