flutter_google_webservices 0.0.3
flutter_google_webservices: ^0.0.3 copied to clipboard

A single plugin to manage Google webservices (Places, Maps)

0
likes
70 / 110
pub points
42 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 254 API elements (1.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

lib/flutter_google_webservices.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/models/matched_substring.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.73.0.104.0.0
flutterflutter0.0.00.0.0
json_annotation^3.0.03.1.14.0.1
retrofit^1.0.1+11.3.4+11.3.4+1
rxdart^0.23.10.23.10.26.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.7` on dio does not support the stable version `4.0.0`, that was published 24 days ago.

When dio is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^3.0.0` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.