flutter_google_cast_button 0.2.0
flutter_google_cast_button: ^0.2.0 copied to clipboard

A Flutter plugin provides cast button which sync cast state with it.

2
likes
70 / 130
pub points
25 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 34 API elements (8.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_google_cast_button/flutter_google_cast_button.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_google_cast_button.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.14.10.14.47.0.0
equatable^0.2.30.2.62.0.3
flutterflutter0.0.00.0.0
flutter_bloc^0.15.00.15.17.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.7.0
rxdart-0.22.60.27.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.14.1` on bloc does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^0.2.3` on equatable does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.3, Dart 2.13.4.

2
likes
70
pub points
25%
popularity

A Flutter plugin provides cast button which sync cast state with it.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, equatable, flutter, flutter_bloc

More

Packages that depend on flutter_google_cast_button