flutter_folioreader 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 38

flutter_folioreader #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_folioreader_example #

Demonstrates how to use the flutter_folioreader plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_folioreader: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_folioreader/flutter_folioreader.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jan 7, 2019 Go to the documentation of flutter_folioreader 0.0.3 Download flutter_folioreader 0.0.3 archive
0.0.2 Jan 7, 2019 Go to the documentation of flutter_folioreader 0.0.2 Download flutter_folioreader 0.0.2 archive
0.0.1 Dec 20, 2018 Go to the documentation of flutter_folioreader 0.0.1 Download flutter_folioreader 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/components/highlight_popup.dart. (-3.93 points)

Analysis of lib/components/highlight_popup.dart reported 8 hints, including:

line 1 col 8: Unused import: 'package:flutter/foundation.dart'.

line 3 col 8: Unused import: 'package:flutter/services.dart'.

line 4 col 8: Unused import: 'package:flutter_folioreader/flutter_folioreader.dart'.

line 8 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: HighlightPopup.onShare, HighlightPopup.onNote, HighlightPopup.onDelete, HighlightPopup.onHighlight, HighlightPopup.highlighted, HighlightPopup.style

line 25 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/folio_book_widget.dart. (-1.99 points)

Analysis of lib/folio_book_widget.dart reported 4 hints:

line 8 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: FolioBookWidget.path, FolioBookWidget.width, FolioBookWidget.height

line 26 col 10: Don't explicitly initialize variables to null.

line 42 col 40: Name non-constant identifiers using lowerCamelCase.

line 55 col 34: Avoid using braces in interpolation when not needed.

Format lib/flutter_folioreader.dart.

Run flutter format to format lib/flutter_folioreader.dart.

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://ohze.co was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
tuple ^1.0.2 1.0.2
Transitive dependencies
collection 1.14.11
matcher 0.12.5
meta 1.1.6 1.1.7
path 1.6.2
quiver 2.0.3
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
vector_math 2.0.8