flutter_firecache 0.0.1 icon indicating copy to clipboard operation
flutter_firecache: ^0.0.1 copied to clipboard

Flutter firecache implementation.

0
likes
100/ 130
pub points
14%
popularity

We analyzed this package 16 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/johannmunoz/flutter_firecache was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 24 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:flutter_firecache/flutter_firecache.dart that imports:
  • package:flutter_firecache/src/firestore_wrapper.dart that imports:
  • package:flutter_firecache/src/firestore_state_manager.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^1.0.71.0.73.1.6
firebase_auth^1.1.01.4.13.3.5
firebase_core^1.1.01.11.01.11.0
firebase_storage^8.0.58.1.310.2.5
flutterflutter0.0.00.0.0
rxdart^0.26.00.26.00.27.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.2.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore_platform_interface-4.0.35.4.11
cloud_firestore_web-1.0.72.6.6
collection-1.15.01.15.0
firebase_auth_platform_interface-4.3.16.1.10
firebase_auth_web-1.3.13.3.6
firebase_core_platform_interface-4.2.34.2.3
firebase_core_web-1.5.31.5.3
firebase_storage_platform_interface-2.1.24.0.12
firebase_storage_web-1.1.23.2.6
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.4
meta-1.7.01.7.0
path-1.8.11.8.1
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.7` on cloud_firestore does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^1.1.0` on firebase_auth does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.