flutter_firebase_ui_kidus 0.0.1

  • Readme
  • Changelog
  • Installing
  • 0

flutter_firebase_ui #

Build Status pub package

Flutter_firebase_ui is a library that help you to quickly implement firebase authentication. It provider UI for the common identity providers, Facebook, Google, Twitter and email.

Note: this plugin use firebase_auth you must configure it as describe here.


Show firebase ui example.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.13] - 19/12/2018

  • update dependencies
  • add twitter

[0.0.12] - 27/09/2018

  • after trouble sign in pop

[0.0.11] - 27/09/2018

  • add function signOutProviders

[0.0.10] - 26/09/2018

  • fixed empty null on Providers
  • allow for usage with landscape orientation

[0.0.9] - 07/09/2018

  • add mail verification option

[0.0.8] - 17/07/2018

  • improve UI

[0.0.7] - 04/07/2018

  • fixe sign in with mail

[0.0.6] - 30/05/2018

  • improve show dialog error

[0.0.5] - 29/05/2018

  • show error occured on unknown errors
  • display email if no displayName (example)
  • secure providers test, firebase_auth behavior change
  • pop sign up !

[0.0.4] - 09/05/2018

  • Upgrade to Google Services 3.2.1 and Google Sign In 3.0.3

[0.0.3] - 23/03/2018

  • dart 2 fix

[0.0.2] - 20/03/2018

  • improve ui
  • change firebase_auth version

[0.0.1] - 19/03/2018

  • initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_firebase_ui_kidus: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_firebase_ui_kidus/email_view.dart';
import 'package:flutter_firebase_ui_kidus/flutter_firebase_ui.dart';
import 'package:flutter_firebase_ui_kidus/l10n/localization.dart';
import 'package:flutter_firebase_ui_kidus/l10n/translations.dart';
import 'package:flutter_firebase_ui_kidus/login_view.dart';
import 'package:flutter_firebase_ui_kidus/password_view.dart';
import 'package:flutter_firebase_ui_kidus/sign_up_view.dart';
import 'package:flutter_firebase_ui_kidus/trouble_signin.dart';
import 'package:flutter_firebase_ui_kidus/utils.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/utils.dart: Target of URI doesn't exist: 'package:flutter_firebase_ui/l10n/localization.dart'.

Health issues and suggestions

Fix lib/utils.dart. (-86.65 points)

Analysis of lib/utils.dart failed with 7 errors, including:

line 9 col 8: Target of URI doesn't exist: 'package:flutter_firebase_ui/l10n/localization.dart'.

line 91 col 18: Undefined name 'FFULocalizations'.

line 97 col 18: Undefined name 'FFULocalizations'.

line 103 col 18: Undefined name 'FFULocalizations'.

line 109 col 18: Undefined name 'FFULocalizations'.

Format lib/email_view.dart.

Run flutter format to format lib/email_view.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/utils.dart: Target of URI doesn't exist: 'package:flutter_firebase_ui/l10n/localization.dart'.

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (firebase_auth, flutter_facebook_login).

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: flutter_twitter_login.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_firebase_ui_kidus.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
firebase_auth ^0.8.0+1 0.8.4+5 0.15.0+1
flutter 0.0.0
flutter_facebook_login ^1.2.0 1.2.0 3.0.0
flutter_twitter_login 1.1.0
google_sign_in ^4.0.0 4.0.14
Transitive dependencies
collection 1.14.11 1.14.12
firebase_core 0.3.4 0.4.2
google_sign_in_platform_interface 1.0.0
meta 1.1.7 1.1.8
quiver_hashcode 2.0.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies