flutter_essentials 0.0.5
flutter_essentials: ^0.0.5

Flutter Android iOS

Essential cross platform APIs for your mobile\desktop\web apps.

0
likes
80 / 110
pub points
37 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 118 API elements (3.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_essentials/flutter_essentials.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Close instances of `dart.core.Sink`.

lib/accelerometer.dart:18:33

   ╷
18 │     static StreamController<bool> shakeDetectedController =
   │ ┌─────────────────────────────────^
19 │ │       StreamController<bool>.broadcast();
   │ └────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/accelerometer.dart

INFO: Override `==` if overriding `hashCode`.

lib/accelerometer.dart:102:11

    ╷
102 │   int get hashCode => acceleration.hashCode;
    │           ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/accelerometer.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
37%
popularity

Essential cross platform APIs for your mobile\desktop\web apps.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

acastr7@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_essentials