flutter_encrypt 1.0.8

flutter_encrypt #

A new flutter plugin project for DES encrypt.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Note #

publish需要终端代理(在terminal输入export http_proxy=socks5:ip,export https_proxy=socks5:ip 仍无效)
shadowsocks + proxifier

proxifier:(1)Proxies add address + port + SOCKS Version 5
(2)Rules Localhost->Target Hosts add address or ip

flutter packages pub publish --server=https://pub.dartlang.org -v

IOS 引入第三方包 (podspec 不支持ssl引入,其它可直接在podespec里引入 s.dependency 'name','~> 版本号')
先在Podfile 里引入 pod 'name', :git => 'xxxxx'
然后在Pods\Developement Pods\Pod\xxx.podspec\ 添加s.dependency 'name'

1.0.0 #

  • DES加密(android)

1.0.1 #

  • DES加密(ios)

1.0.2 #

  • 修复ios加密bug

1.0.3 #

  • 修复ios加密bug

1.0.4 #

  • 修复ios加密bug

1.0.5 #

  • 修复ios加密bug

1.0.6 #

  • 修复ios加密bug

1.0.7 #

  • 修复ios加密bug

1.0.8 #

  • 修复ios加密bug

example/README.md

flutter_encrypt_example #

Demonstrates how to use the flutter_encrypt plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_encrypt: ^1.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_encrypt/flutter_encrypt.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/des_encrypt.dart. (-1 points)

Analysis of lib/src/des_encrypt.dart reported 2 hints:

line 1 col 8: Unused import: 'package:flutter/material.dart'.

line 18 col 35: The exception variable 'e' isn't used, so the 'catch' clause can be removed.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/juggist/flutter_encrypt_lib was unreachable.

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin