flutter_easyrefresh_extend 2.1.6

Flutter Android iOS web

A flutter widget that provides pull-down refresh and pull-up load.

example/lib/main.dart

import 'package:example/generated/i18n.dart';
import 'package:example/page/home.dart';
import 'package:flutter/material.dart';
import 'package:flutter_localizations/flutter_localizations.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      // App名字
      title: 'EasyRefresh',
      // App主题
      theme: new ThemeData(
        primarySwatch: Colors.orange,
      ),
      // 主页
      home: HomePage(),
      localizationsDelegates: [
        S.delegate,
        GlobalCupertinoLocalizations.delegate,
        GlobalMaterialLocalizations.delegate,
        GlobalWidgetsLocalizations.delegate
      ],
      supportedLocales: S.delegate.supportedLocales,
      localeResolutionCallback: S.delegate.resolution(),
    );
  }
}
0
likes
90
pub points
0%
popularity

A flutter widget that provides pull-down refresh and pull-up load.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

qiukujun@gmail.com

License

MIT (LICENSE)

Dependencies

cupertino_icons, flutter

More

Packages that depend on flutter_easyrefresh_extend