flutter_bl_umpush 0.0.8
flutter_bl_umpush: ^0.0.8 copied to clipboard

A new flutter plugin project.

1
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis http://wwww.topsports.com was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 29 API elements (24.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_bl_umpush/flutter_bl_umpush.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/flutter_bl_umpush.dart:26:3

   ╷
26 │ ┌   /**
27 │ │    * 监听:接收推送事件
28 │ └    */
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_bl_umpush.dart

INFO: Prefer using /// for doc comments.

lib/flutter_bl_umpush.dart:37:3

   ╷
37 │ ┌   /**
38 │ │    * 监听:接收推送事件
39 │ └    */
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_bl_umpush.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
80
pub points
0%
popularity

A new flutter plugin project.

Homepage

Documentation

API reference

Uploader

wgpvincent@gmail.com

License

LICENSE

Dependencies

flutter

More

Packages that depend on flutter_bl_umpush